Convert to XML not translating unicode characters correctly

If you have a new question you’d like our support staff to post a response to, please visit our customer community, Data Security Insiders, to pose the question in our Discussion Boards. We have a thread “Ask Our Tech Experts” that our support team monitors on a regular basis, or you can start a new discussion where other GoAnywhere users and support staff can weigh in. Log in or create your new account at https://insiders.helpsystems.com/sign_in.

If you need an immediate response, please create a support ticket or contact our support team by email at [email protected].
2 posts Page 1 of 1

john_a

Posts: 9
Joined: Tue Nov 03, 2015 5:35 pm

Post by john_a » Mon Jan 18, 2016 6:32 pm
It appears that GoAnywhere is replacing the good \u2122 unicode trademark character with the invalid \u001a character. This creates an XML document that cannot be validated. It may also be replacing other good unicode characters, copyright etc. with that bad character.

I also, as a sanity check, ran the same job only creating a CSV instead of XML file and I experienced the same issue.

Has anyone else experienced this and is there a solution to fix this problem?

Support_Rick

Support Specialist
Posts: 592
Joined: Tue Jul 17, 2012 2:12 pm
Location: Phoenix, AZ

Post by Support_Rick » Fri Jan 22, 2016 9:38 am
John,

Can you send us the Project Code and Job Log of what you're doing to get this? We would like to run test here to verify what his happening and make sure we can re-create the same issue.

You can email the project and debug joblog to [email protected]. Send it to my attention. Also send any test CSV or actual data you are testing with if possible.

Thanks!
Rick Elliott
Lead Solutions Consultant
(402) 944.4242
(800) 949-4696
2 posts Page 1 of 1