DeleteWorkspace doesn't delete the folder

Post any question you may have in regards to GoAnywhere MFT and let our talented support staff and other users assist you.
3 posts Page 1 of 1

jstanley

Posts: 3
Joined: Thu Nov 12, 2015 6:33 pm

Post by jstanley » Thu Nov 12, 2015 6:40 pm
I've noticed that DeleteWorkspace is not deleting the folder, but it is deleting the contents. Is this by some off chance by design? If so what are the alternatives so I don't end up with a wealth of empty folders?



I'm on running MFT 5.1.2 on a Windows Server 2008 r2.



Thanks!

Support_Rick

Support Specialist
Posts: 592
Joined: Tue Jul 17, 2012 2:12 pm
Location: Phoenix, AZ

Post by Support_Rick » Fri Nov 13, 2015 5:48 pm
I just tried to recreate that here and can't make that happen.

Can you send in your Project XML & JobLog from creating this workspace, processing, deleting the workspace and a snapshot of the Workspace before and after that include the job you ran?

Also, what user is running the GAMFT Service? Does it have full authority to files/folders locally?

Please advise...
Rick Elliott
Lead Solutions Consultant
(402) 944.4242
(800) 949-4696

jstanley

Posts: 3
Joined: Thu Nov 12, 2015 6:33 pm

Post by jstanley » Fri Nov 13, 2015 10:54 pm
Hi Rick,

So your response prompted me to create a test project and document the steps to reproduce this behavior. Something I should have done from the beginning....

With that, I discovered that I cannot duplicate this either. I had a scoping issue with the delete workspace task in a project template that we created.There was an if condition that when true, it exited the project before the delete workspace task fired.


Thanks for the help and in the future I will test thoroughly before posting!

-Justin
3 posts Page 1 of 1