Page 1 of 1

JCE cannot authenticate the provider BC

Posted: Fri Apr 23, 2021 3:43 pm
by Support_Jerrod
The error java.lang.SecurityException: JCE cannot authenticate the provider BC
at javax.crypto.Cipher.getInstance(Unknown Source)
has been reported after applying
  • PTF Group SF99730 Level 20310.
The update breaks PGP encryption/decryption. Other issues around encryption/ciphers may be encountered with SFTP/AS2 as well.

The update only affects customers running on older (5.X) versions of GoAnywhere MFT installed on the iSereies.

Resolution/Workaround Options:
  • Revert the PTFs
  • Upgrade GoAnywhere MFT to version 6.0.4 or later.
  • In some rare instances, switching to another version of Java may resolve. If running on java 7,try Java 8 (changing-java-1122)