Oracle Java 8 licensing changes and GoAnywhere MFT

View some of the Frequently Asked Questions to our support staff. Included are some tips and tricks making this forum ideal for users getting started with GoAnywhere MFT. Note: Users can reply to existing topics but only our support staff can add new topics to this forum.
1 post Page 1 of 1

Support_Josh

User avatar
Posts: 12
Joined: Thu Feb 16, 2017 11:20 am

Post by Support_Josh » Wed Nov 21, 2018 9:30 am
Question:
Will Oracle's Java 8 licensing changes affect GoAnywhere MFT?

Answer:
With the upcoming licensing changes coming to Oracle in January 2019 we have done extensive research into how this impacts GoAnywhere MFT. We can confirm that if you are still using a free version of Java in your current environment, that it will continue to be usable through the 2019 changes. This license change impacts new updates of Java 8, after January 2019.

Moving forward, we are going to be using Azul Zulu JRE (OpenJDK), this will be applied to all new installations as of MFT version 6.0. Old installations will still be running on either the default installed Java or any externalized Java that has been migrated to, on a per company basis. If you choose to go with an external JRE, you are responsible for licensing and managing that Java environment. If you choose not to externalize, we will provide an embedded Java option for you to use.

When upgrading to version 6.0 of MFT, Java 8 is required. In our upgrade guide, as of version 6.0, we explicitly document the process to determine whether you are on Java 8, and if not, how to utilize Java 8 in your GoAnywhere MFT environment. This includes both 32 and 64 bit JRE’s, 1.8.0.131, and 1.8.0.191, respectively. Please remember this is applicable to the embedded JRE. If you are using your own external JRE, this does not apply.
Joshua Przybysz
Senior Support Analyst
e. goanywhere.support@helpsystems.com
p. 1.800.949.4696
w. HelpSystems.com
1 post Page 1 of 1