Skip first row?

Post any question you may have in regards to GoAnywhere Director and let our talented support staff and other users assist you.
3 posts Page 1 of 1

wfpturner

Posts: 7
Joined: Fri Jun 20, 2014 10:00 am

Post by wfpturner » Fri Jun 20, 2014 1:53 pm
I am using the ReadCSV task to process records from a downloaded file.

I use the Data feature in the ReadCSV task to specify and setup each column/index.

The first record on the file is a header record with 4 columns - I need to bypass this record. The remaining records are detail records with 256 columns.

I set the Skip First Row field on the ReadCSV task to TRUE, but either it's not working or I'm using it in an invalid manner.

The project execution blows up with the message Read Data File(s)] Invalid column index '5'. Input file contains only '4' columns. This is telling me that it's trying to process the first record which is the header record.

Am I attempting to use the Skip First Row value in a way other than what is was intended? I have attached the XML view of my project if this helps.
Last edited by wfpturner on Mon Jul 07, 2014 12:34 pm, edited 1 time in total.

Support_Rick

Support Specialist
Posts: 592
Joined: Tue Jul 17, 2012 2:12 pm
Location: Phoenix, AZ

Post by Support_Rick » Fri Jun 20, 2014 5:12 pm
No matter whether you're reading or skipping the 1st row, it has to match up with the rest of the document. So, you either need to delete the first record (header row) or add a comma to make it think it has 5 columns (even if you skip that row based on configuration settings)

For the Read to work, even skipping the header rec, it has to match the rest of the doc.

Let me know if that helps!
Rick Elliott
Lead Solutions Consultant
(402) 944.4242
(800) 949-4696

kgutierrez

Posts: 6
Joined: Fri Aug 28, 2015 11:42 am

Post by kgutierrez » Tue Nov 15, 2016 1:06 pm
This is the exact issue I'm having right now. Is there a way to download and decrypt the file (which works fine) and then programmatically delete the first record out of the file before trying to read and insert into table? This is an issue with every file we download as they all have header records so need to figure out a way around this that doesn't involve a manual process.
3 posts Page 1 of 1